Faire fonctionner Ubuntu et l'interface Unity avec VirtualBox


VirtualBox
Ubuntu 11.04 propose une nouvelle interface appelée "Unity". Celle-ci ne fonctionne pas très bien avec le logiciel VirtualBox, et c'est l'interface classique de Gnome qui se lance par défaut. Pour remédier à ce problème, voici quelques étapes à suivre.

Unity

  1. Installez VirtualBox version 4.0 ou supérieure.
  2. Activez l'accélération 3D lors de la configuration de la machine virtuelle.
  3. Installez et lancez ensuite Ubuntu 11.04. Normalement, le système se lance avec une session Gnome classique.
  4. Ouvrez un terminal et lancez les commandes suivantes pour installer les "Additions invité" depuis les dépôts Ubuntu (et non pas ceux fournis par VirtualBox) :
  5. sudo apt-get update
    sudo apt-get install virtualbox-ose-guest-utils

  6. Relancez le système. Unity devrait alors fonctionner correctement.

En revanche, chez moi, je me suis retrouvé avec un thème blanc pas très beau. Vous pouvez remettre le thème Dark proposé par défaut, comme ceci :

killall -9 gnome-settings-daemon && gnome-settings-daemon


10 Commentaires pour "Faire fonctionner Ubuntu et l'interface Unity avec VirtualBox"

Flux des commentaires de cet article Ajouter un commentaire
  •  

    Merci,

    J'étais en train de télécharger VirtualBox et Ubuntu 11.04 afin de tester quand soudain : je tombe sur cet article. Le hasard ....

    RépondreRépondre
    Paul , le 21 avril 2011 à 10:33
  •  

    @Paul : le hasard fait bien les choses ... :-)

    RépondreRépondre
    pti-seb , le 21 avril 2011 à 13:13
  •  

    VirtualBox proposait aussi sur son site une mise à jour des Additions invité pour X.org11, qui m'a permis de faire fonctionner Unity sous Ubuntu 11.04. Unity a supporté également la dernière mise à jour de VirtualBox (4.0.6) ce soir.
    Malheureusement, je suis assez déçu par cette interface...

    RépondreRépondre
    Pat , le 21 avril 2011 à 21:54
  •  

    Bonjour. Merci pour l'astuce.
    Cependant, chez moi cela n'a rien réglé.
    J'avais installé Virtualbox 3 ose pris dans les dépôts puis fait l'installation de 11.4 beta 2 et comme unity ne fonctionnait pas j'ai suivi ton tuto et installé virtualbox 4.0.6 pris sur le site de virtualbox, ainsi que les guest-utils comme tu le proposais. Je me suis servi du vdi installé avant et unity ne fonctionne toujours pas.
    Je tente une nouvelle installation car cela vient peut-être du fait que mon installation d'Ubuntu était faite sur vb 3 et non vb 4 au départ...

    RépondreRépondre
    Sakka , le 25 avril 2011 à 08:57
  •  

    ... de retour.
    Effectivement dans ce sens cela fonctionne.
    Donc je résume, il faut avoir d'abord installé virtualbox 4.0.6 avant de faire une installation de ubuntu 11.04 beta 2 et suivre donc le tuto à la lettre.

    On ne peut pas réutiliser une installation faite avec virtualbox 3.

    Si ça peut servir....

    RépondreRépondre
    Sakka , le 25 avril 2011 à 10:31
  •  

    Quand je tape "killall -9 gnome-settings-daemon && gnome-settings-daemon" dans le terminal ça fonctionne mais je suis obligé de refaire cette commande à chaque démarrage de Ubuntu, il n'y a pas une autre commande ? De plus ça change que la barre, pas le clique droit, les icones du navigateur...

    RépondreRépondre
    DarkestNights , le 28 avril 2011 à 14:06
  •  

    Avec la version 4.0.6 de Virtual BOX, les guest addition fournis par défaut permettent de lancer unity après avoir activé la 3d dans les paramètres de la machine virtuelle.

    RépondreRépondre
    Calvin0c7 , le 28 avril 2011 à 21:53
  •  

    Merci pour ce tuto.

    Pour moi, avec la MAJ 11.04 officielle, j'avais ce problème. Par contre, l'installation de "virtualbox-ose-guest-utils" a généré des erreurs signalant que la version installée des "additions VirtualBox" étaient plus récentes que celles ajoutées avec OSE (4.0.4 vs 4.0.6) ???

    Je ne vois pas bien le rapport entre OSE et VB, mais bon, ça semble fonctionner. À suivre.

    RépondreRépondre
    Piotr58 , le 30 avril 2011 à 13:10
  •  

    Boujour,

    Pour info sous VitualBox 4.0.6 et windwos 7 (64bit), au redémarrage, la VM plantée.
    J'ai désactiver l’accélération 3D, lancer ubuntu, suivi les infos suivantes
    http://forum.ubuntu-fr.org/viewtopic.php?id=463901
    (en fait il installe pas tout les paquets de Unity)
    puis j'ai ré-activer la 3D et relancer le tout et ça marche

    RépondreRépondre
    vince84 , le 12 mai 2011 à 09:45
  •  

    super, ca c de la solution
    ca a fonctionné du premier coup
    windows7, vbox 4.1

    RépondreRépondre
    gn , le 28 juillet 2011 à 08:01
 

Ajouter un commentaire

actualité android apache apple astuce astuces bash bilboblog blog boot chrome clavier commande commandes conky date debian Desktop développement elementary exploit faille fedora firefox flash gimp gnome google graphique Graphisme hack hacking Hardware humour intel internet iphone jailbreak Jeux Kde kernel libre Linux log logiciels Logiciels Libres lucid lynx maemo mail maquette metasploit microsoft mobile mockup monitoring mozilla multi-touch musique mysql n900 nautilus nokia noyau openoffice open source password photos php Planet publicité red hat redhat rpm réseau screenshot script serveur serveurs shell sql ssh statistiques sysadmin system Sécurité thème tux-planet tv twitter ubuntu unity vidéo vidéos vlc voyage wallpaper windows wordpress yum