Installation du plugin flash sur une Fedora Core 64 bits


firefox
Cette méthode explique comment installer le plug-in flash sur une Fedora Core en version 64 bits (x86_64). Étant l'auteur de la documentation déjà présente sur le wiki de Fedora-france, j'ai décidé également de vous présenter la méthode sur mon site avec quelques petites nouveautés tout de même.

L'un des grands inconvénients à utiliser une machine 64 bits avec un système d'exploitation adéquate, est que certains logiciels (propriétaires ?) ne sont pas disponibles en version x86_64. Le plugin Fash en est l'un des plus célèbres exemples.

Pour y remédier, il suffit d'installer une version 32 bits du navigateur firefox sur sa fedora, pour pouvoir ensuite installer normalement ce plugin.

1. Préparation

Ajoutez ceci à la fin du fichier /etc/yum.repos.d/fedora-core.repo :

[core-i386]
name=Fedora Core $releasever - i386
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/
$releasever/i386/os/ gpgcheck=1 enabled=0

et ceci au fichier /etc/yum.repos.d/fedora-updates.repo :

[updates-i386]
name=Fedora Core $releasever - i386 - Updates
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/
updates/$releasever/i386 gpgcheck=1 enabled=0

2. Installation

Si vous avez déjà un firefox sur votre système, lancez d'abord la commande :

yum remove firefox

Puis lancez l'installation de la version 32 bits :

yum --enablerepo=core-i386 --enablerepo=updates-i386 install firefox.i386

Il ne reste plus qu'à installer normalement le plugin flash pour votre Fedora Core (cf. Flash : Installation du plug-in).


9 Commentaires pour "Installation du plugin flash sur une Fedora Core 64 bits"

Flux des commentaires de cet article Ajouter un commentaire
  •  

    Pour commencer, pardon pour mon mauvais français. :-D

    Il existe un plugin qui fais le pont entre les différentes architectures, il a le "plugin-viewer" qui lance à la fois en 32 bits et 64 bits.

    Ces deux derniers communiques avec des méthode RPC normale.

    Je l'utilise chez moi et cela marche plutôt pas mal, bien que de temps en temps, il y a des disfonctionnements, mais on peu le tuer sans toucher à firefox.

    Son site internet est http://www.gibix.net . Ce dernier n'était pas libre, mais l'auteur à changé dernièrement sa licence pour le passer en GPL.

    Peut-être j'ai devrais écrire ce commentaire en anglais, mais je dois pratiquer mon français aussi. :)

    RépondreRépondre
    Victor Bogado , le 9 juin 2006 à 20:40
  •  

    Effectivement ton français n'est pas parfait, et j'ai légèrement retouché ton commentaire afin qu'il soit plus compréhensible.

    Pour ce qui est du plugin, si on va sur le site officiel, on peut trouver une description anglaise qui est la suivante :

    Nspluginwrapper consists in a proxy plugin and a viewer for Netscape 4 compatible plugins. It makes it possible to use 32-bit x86 plugins like Macromedia Flash with x86_64 compiled Mozilla browsers.

    @Victor Bogado : merci pour l'astuce, il ne me reste plus qu'a la tester !
    And you can write in english if you want ... :-D

    RépondreRépondre
    pti-seb , le 9 juin 2006 à 21:02
  •  

    I am learning french, and for now I think I can understand it better then I can write it. I usually take more time to writeit and check several times in dictionaries and other online tools. But I was in a little hurry, so this comment was made in a more "quick and dirty" way. :-P

    My natural language, portuguese, is somewhat similar to the french, what I believe is what make's it harder for me as they are similar and the same time very different. I also had not trained in while, I like to watch movies in french and I read the libé on the internet. I do want to watch the movie "caché" that is curently being shown here in Rio de Janeiro.

    Thanks for the corrections, I was going to ask to you for doing exactly that, but I was afraid of asking too much.

    RépondreRépondre
    Victor Bogado , le 9 juin 2006 à 22:17
  •  

    Cela ne fonctionne pas.
    Fedora core 5 x86_64

    RépondreRépondre
    cortex , le 14 septembre 2006 à 20:14
  •  

    @Cortex : dir que cela ne fonctionne pas ne fera pas vraiment avancer les choses. Un message d'erreur peut-être ??

    RépondreRépondre
    pti-seb , le 14 septembre 2006 à 21:17
  •  

    Tu donne la variable $releasever dans les changements j'ai une erreur dessus. A quoi correspond cette variable ?
    Erreur :

    # yum remove firefox
    Loading "installonlyn" plugin
    Config Error: File contains parsing errors: file://///etc/yum.repos.d/fedora-core.repo
    [line 28]: '6/i386/os/ '

    RépondreRépondre
    CliMz , le 29 décembre 2006 à 18:37
  •  

    $releasever correspond au numéro de version de fedora core.

    RépondreRépondre
    pti-seb , le 29 décembre 2006 à 23:36
  •  

    Le copier/coller prend le retour à la ligne, il faut le supprimer dans le fichier fedora-core.repo pour que le "baseurl" ne soit que sur une ligne

    RépondreRépondre
    furai , le 8 janvier 2007 à 00:01
  •  

    Auteur de la documentation déjà présente sur le wiki de fedora-france, j'ai du mal à comprendre, j'avoue :) en tout cas merci pour ce billet intéressant ! c'est toujours sympathique de passer sur ce blog :)

    RépondreRépondre
    Compositeur , le 17 juin 2008 à 20:19
 

Ajouter un commentaire

actualité android apache apple astuce astuces bash bilboblog blog boot chrome clavier commande commandes conky date debian Desktop développement elementary exploit faille fedora firefox flash gimp gnome google graphique Graphisme hack hacking Hardware humour intel internet iphone jailbreak Jeux Kde kernel libre Linux log logiciels Logiciels Libres lucid lynx maemo mail maquette metasploit microsoft mobile mockup monitoring mozilla multi-touch musique mysql n900 nautilus nokia noyau openoffice open source password photos php Planet publicité red hat redhat rpm réseau screenshot script serveur serveurs shell sql ssh statistiques sysadmin system Sécurité thème tux-planet tv twitter ubuntu unity vidéo vidéos vlc voyage wallpaper windows wordpress yum