Montage vidéo sous Linux avec OpenShot


Camescope
Il y a quelques temps, je vous avais présenté le logiciel de montage vidéo Kino. Sachez qu'il en existe un autre du nom d'OpenShot. Celui-ci fait partie de la même catégorie de logiciels, c'est-à-dire ceux qui permettent de réaliser des montages vidéos sous Linux de façon ultra-simple.

Voici un screencast qui montre comment OpenShot fonctionne :

Pour installer OpenShot sur une distribution à base de rpm, il faudra utiliser les rpm disponible ici.

Pour une distribution à base de Debian, lancez les commandes suivantes :

sudo add-apt-repository ppa:jonoomph/openshot-edge
sudo apt-get update
sudo apt-get install openshot

Vous pourrez ensuite lancer le logiciel à l'aide de la commande openshot et commencer vos montages vidéos.


13 Commentaires pour "Montage vidéo sous Linux avec OpenShot"

Flux des commentaires de cet article Ajouter un commentaire
  •  

    Merci, ce logiciel sympa va m'aider ;).

    RépondreRépondre
    Swopyl , le 8 décembre 2009 à 20:02
  •  

    Attention toutefois, il met le bordel dans gstreamer et on ne peut plus lire de videos sous vlc ou totem. Il vaut mieux attendre que ce probleme soit solutionné.
    cordialement

    RépondreRépondre
    obrowny , le 8 décembre 2009 à 23:44
  •  

    @Swopyl : de rien.

    @obrowny : le dépôt indiqué ici est un nouveau dépôt qui corrige ce problème. En faite, cela fait un moment que j'ai rédigé cet article, mais j'attendais que le souci soit réglé pour en parler.

    Voila d'ailleurs le message de l'auteur qui indique que le problème est résolut :

    It is safe to install and uninstall, and is now friends with VLC, Totem, and all other FFmpeg-based packages! I repeat... it "should not" screw up your FFmpeg version or uninstall VLC.

    RépondreRépondre
    pti-seb , le 8 décembre 2009 à 23:52
  •  

    slt Seb,

    je pense que tu as fais une erreur
    tu écris " sudp apt-get install openshot "

    je pense que c'est plutôt " sudo apt-get install openshot "

    autrement super site je vais le voir tout les jours.

    continu c'est du super travail cousin

    fabrice

    RépondreRépondre
    fabrice , le 9 décembre 2009 à 00:00
  •  

    C'est génial !!! J'avais arreter de faire des petits videos montages des vacances avec les potes quand je suis passé sous Linux parceque c'était moins intuitif que Windaube Movie Maker mais celui la m'a l'air meme mieux !!! Un pote m'avais meme posé la colle en me disant "et si je passe sous Linux je remplace WMM par quoi ?"

    Par contre c'est quoi la config de la machine pour la demo parceque ça rame pas un brin et c'est trés fluide !!

    RépondreRépondre
    Federico_muy_bien , le 9 décembre 2009 à 08:42
  •  

    @fabrice : arf, bien vu, il y a une faute de frappe. Merci cousin ! :-)

    @Federico_muy_bien : je sais pas pour la conf de la machine. Chez moi, le logiciel lag un petit peu. Ce soft est encore un peu jeune et possède donc pas mal de défaut, mais les développeurs sont actifs. Ce projet devrait donc évoluer d'une façon positive.

    RépondreRépondre
    pti-seb , le 9 décembre 2009 à 08:45
  •  

    Salut,

    ça fait longtemps que je cherche LE logiciel qui fonctionne sous
    linux pour faire des montages et le seul qui tient à peu près la route
    c'est kdenlive et là on sent la resucée si c'est pas carrément
    le plagiat !

    RépondreRépondre
    ponky , le 9 décembre 2009 à 14:29
  •  

    Est ce que tu sais comment récupérer Totem et vlc suite au bug de la version précédente sans réinstaller ma distrib. Je cale et ça me saoule de tout réinstaller...
    j'ai supprimé tous les lecteurs et config, réinstallé tous ce qui concerne ffmpeg, gstreamer et ça ne marche toujours pas...:-(

    RépondreRépondre
    obrowny , le 10 décembre 2009 à 11:32
  •  

    @obrowny : au faite, le bug de l'ancien dépôt ne vient pas d'OpenShot, mais de MLT, le framework vidéo utilisé par OpenShot.

    J'ai fait une recherche rapide sur le terme "Uninstall Openshot". Pour se débarrasser des anciens bugs, il suffit de désinstaller l'ancien paquet OpenShot et son dépôt, de mettre le nouveau dépôt, et de réinstaller OpenShot. Normalement, les bonnes version de MLT/ffmpeg devraient suivre ...

    RépondreRépondre
    pti-seb , le 10 décembre 2009 à 12:15
  •  

    Bonjour et merci pour l'article.

    @Ponky : Il n'y a malheureusement que 2 frameworks vidéo sous linux, gnonlin de gstreamer et mlt. Openshot utilise aussi mlt comme kdenlive mais cela ne fait pas de nous des pliageurs. D'ailleurs initialement Openshot utilisait gnonlin mais devant le peu de résultat Jonathan Thomas l'auteur a swithcher sur mlt et proposer ce que l'on connait actuellement. Si tu veux voir l'évolution du logiciel dés le début, un membre de la communauté d'Openshot a résumé tout ça ici.

    @pti-seb : Il existe maintenant un paquet pour Fedora 12 et l'info est par ici.

    Le forum international dont une section française existe aussi : http://openshotusers.com/forum/index.php

    Pour info, Openshot fonctionne sur des configs modestes dont sur un P4 Northwood de 2.4 ghz avec 500 Mo de Sdram sans problème mais c'est mieux sur un corei5 :) .

    RépondreRépondre
    Cenwen , le 13 décembre 2009 à 21:57
  •  

    @Cenwen : merci pour l'info. J'ai rajouté un lien vers les rpm pour Fedora.

    RépondreRépondre
    pti-seb , le 15 décembre 2009 à 12:46
  •  

    Bonjour,
    Pour info, Openshot n'est développé que par une seule personne, utilise le framework MLT une version antérieure de MLT (qu'il faut compiler soit même et ça fout la merde avec les autres logiciels) qui est basé sur une ancienne version des librairies de ffmpeg. Ca fait beaucoup de couches...
    Pour moi, c'est un logiciel qui ne sera jamais stable...

    RépondreRépondre
    toto , le 9 avril 2010 à 16:39
  •  

    @Toto : pour info, hormis le fait que tu n'aime pas ce logiciel, il me semble que tu es mal informé sur l'état d'avancement du projet Openshot.
    Initialement développé par une seule personne, une équipe internationale s'est montée autour de ce projet prometteur. Regarde ici.

    La dernière version sur Lucid utilisera la dernière version de MLT qui utilisera aussi la version de FFmpeg soit celle du dépôt officiel soit celle de Medibuntu (conseillée si tu veux le support de l'AVCHD). La majorité des autres distributions utilisent une version récente de MLT et de FFmpeg. Plus de détails ici sur les distributions concernées.

    Enfin, un sondage réalisé par l'excellent site Webup8 est ici (un autre aussi ici) et comme tu le constateras, parmi le trio gagnant, il y a deux logiciels utilisant MLT : Openshot et Kdenlive, et tous les 3 utilises FFmpeg.

    RépondreRépondre
    Cenwen , le 9 avril 2010 à 18:50
 

Ajouter un commentaire

actualité android apache apple astuce astuces bash bilboblog blog boot chrome clavier commande commandes conky date debian Desktop développement elementary exploit faille fedora firefox flash gimp gnome google graphique Graphisme hack hacking Hardware humour intel internet iphone jailbreak Jeux Kde kernel libre Linux log logiciels Logiciels Libres lucid lynx maemo mail maquette metasploit microsoft mobile mockup monitoring mozilla multi-touch musique mysql n900 nautilus nokia noyau openoffice open source password photos php Planet publicité redhat red hat rpm réseau screenshot script serveur serveurs shell sql ssh statistiques sysadmin system Sécurité thème tux-planet tv twitter ubuntu unity vidéo vidéos vlc voyage wallpaper windows wordpress yum